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CHAPTER 1 RESOURCE LEVELLING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this session you will: 

 gain an understanding of resource over allocations 

 learn how to create resource chaos in a project 

 learn how to track down resource over allocations using 
the Resource Graph 

 learn how to check Resource Usage for over-allocations 

 learn how to create an over-allocated resources report 

 learn how to change work effort to fix over allocations 

 gain an understanding of assigning overtime to resources 

 learn how to assign overtime to fix over-allocations 

 learn how to assign contract labour to fix over-allocations 

 learn how to switch work assignments to fix over 
allocations 

 learn how to reschedule tasks to fix over allocations. 

Ideally you will always have enough resources to complete the 
tasks in your project. However, this is not always the case and 
sometimes you will not have enough resources for the work you’ve 
scheduled. This is known as over-allocation. 

Resources become over-allocated in a project when they are 
scheduled to do more work than can be accomplished in the 
specified time. Resource levelling resolves any over-allocations 
which exist in your project. 

Project gives you two options when levelling – letting Project level 
the schedule for you, or resolving the resource over-allocations 
yourself. 

INFOCUS 
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UNDERSTANDING RESOURCE LEVELLING 
 

 

 

 

  

 

Levelling refers to the even allocation of 
resources. When you assign more resources to a 
task than you have available the resource is said 
to be over-allocated and requires levelling. 

Sometimes over-allocation is also referred to as a 
resource conflict – you simply have too much work 
for a resource to do.  

Resolving Resource Conflict Using Levelling 

Resource conflicts occur normally when you are entering the resources against the tasks. You may not 
have noticed that the same resource is required in more than one place. However, because Project is 
constantly recalculating the start and finish dates it is able to provide you with accurate details about 
these overlaps, or over-allocations, in work commitments. 

The process of resolving these over-allocations is called levelling (or leveling). This term stems from 
the fact that in an ideal project, all of your resources will be spread evenly, or flatly, across the scope of 
tasks. An over-allocation suggests that you have a bump or peak usage that needs to be evened out. 

Project has a special Resource Graph view as shown below which demonstrates this concept of over-
allocation and levelling. 

In the graph, the thicker line 
at 500% indicates that this 
is the maximum units that 
we have in the resource 
pool. Any bar above this line 
indicates an over-allocation 
of resources. This peaking 
needs to be eliminated. 

Project provides you with 
the ability to automatically or 
manually level over-
allocations. 

If you choose automatic levelling, Project will attempt to resolve the conflict for you. Usually this is 
done by slipping the task dates out. It does this by adding delay to the tasks so that resources are not 
required at the same time. However, with automatic levelling you do forfeit control over your project. 
Most people prefer to resolve over-allocations manually. 

This can be done by: 

 moving a task that has an over-allocated resource within the project so that the task dates are 
changed to a date when the resource is free 

 increasing the maximum units of the resource (usually by hiring or seconding additional staff) 

 assigning a different resource that is currently free to the task 

 assigning overtime 

 extending working days on the calendar used by the resource so that more time is available 
to work on the tasks. 

Obviously not all of these options are practical. For example, if you have a deadline to meet, slipping the 
task dates by moving the task further down the timeframe is not a good idea. In this circumstance you 
may be better off hiring more staff or allocating another resource to the task. 

Similarly, if your project is constrained by costs then you may need to slip the dates out rather than hire 
or buy additional resources or allocate overtime to the task. 
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CREATING RESOURCE PROBLEMS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
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 Before starting this 

exercise you MUST open 
the file Levelling_1.mpp... 

 
Click on the Project tab, 
then click on Project 
Information in the 
Properties group 

The case study project is 
currently scheduled to 
finish on Wednesday April 
22… 

 
Click on [OK] to close the 
dialog box 

 
Click on the View tab, then 
click on Resource Sheet 
in the Resource Views 
group 

 
Click on 200% in Max for 
Draftsperson, type 100% 

and press  

 
Point to the warning icon 
and read the message that 
appears 

 
Repeat step 4 and change 
the number of resource 
units for the following 
resources: Rigger 500%, 
Carpenter 600%, Driver 
200% 

 

For Your Reference… 

To create resource problems: 

 Reduce the number of units of a resource 

Handy to Know… 

 Over-allocations occur when more resources 
are assigned to a task than there are units in 
the resource pool. For example, Project will 
allow you to assign ten carpenters to a task 
even though only five exist in the resource 
pool. 

Our case study project is functional – we have 
ample resources to complete the required tasks. 
However, the project manager has just been 
advised that a second project is to begin 

elsewhere and some of the resources he has in the 
resource pool will be taken away to work on the 
new project. Having carefully assigned resources to 
the various tasks this will now cause problems. 

4 This action has effectively halved the drafting resources in your 
project. Since there were more resources available when you did the 
initial assignments there are now times when the resource is over 
committed. Our committed (allocated) resources appear in red. A 
warning icon appears in the left column. 
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TRACKING DOWN OVER ALLOCATIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Over allocations aren't immediately apparent, 
unless they arise when you are changing data in 
the resource sheet as we have done. 
Over-allocations can be problematic and it is a 

good idea to check the resource pool on a regular 
basis to see whether there are over-allocations in 
your project. Remember, over-allocated resources 
appear bolded red in the resource pool.  

Try This Yourself: 

S
a

m
e

 

F
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 Continue using the previous 

file with this exercise, or open 
the file Levelling_2.mpp... 

 
Click on the View tab, then 
click on Other Views in the 
Resource Views group and 
select Resource Graph 

 
Press  +  , then  +

 to move to the start of the 

project  

 
Press  until the 

Draftsperson comes into view 

This resource is over-allocated 
as indicated by the colouring 
of the name and in the chart… 

 
Press  until you can see 

the Rigger, then press  + 

 to return to the start of 

the project 

 
Click on the Resource tab, 
then click on Next 
Overallocation in the Level 
group to see the over-
allocation for the Riggers 

 
Click on Next Overallocation 
again – you will be advised 
that there are no more 
over-allocations for this 
resource 

 
Click on [OK] 

 
Repeat steps 4 to 7 with the 
Carpenter resource 

 

3 

4 

For Your Reference… 

To display over-allocations as a chart: 

1. Click on the View tab, then click on Other 
Views in the Resource Views group and 
select Resource Graph 

2. Click on the over-allocated resource 

3.  Click on the Resource tab, then click on the 
Next Overallocation command 

Handy to Know… 

 There are a few ways to resolve over-
allocation issues, including changing how 
long a task will take to complete and 
assigning more resources to a task. 
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CHECKING RESOURCE USAGE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Another great way of tracking over-allocations, 
and more importantly the extent of over-
allocation, is through the Resource Usage view. 
This view presents a sheet to the left which is 

organised in order of resources and the tasks that 
they are working on. To the right is a timeline view 
which shows the hours the resource works. Over 
allocated resources appear in red colouring.  

Try This Yourself: 

S
a

m
e

 

F
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Continue using the 
previous file with this 
exercise, or open the 
file Levelling_3.mpp... 

 
Click on the View tab, 
then click on Resource 
Usage in Resource 
Views 

 
Press  +  to 

move to the top of the 
resource list 

 
Scroll to and click on 
Draftsperson, click on 
the Task tab, then click 
on Scroll to Task in the 
Editing group to 
display the usage 
information for this 
resource 

 
Scroll to and click on 
Rigger and click on 
Scroll to Task in the 
Editing group to 
display the usage 
information for this 
resource 

 

2 

3 

For Your Reference… 

To check for over-allocations in resource usage: 

1. Click on the View tab, then click on 
Resource Usage in the Resource Views 
group 

2. Scroll to over-allocated resources  

Handy to Know… 

 At the time of writing, we found that the Next 
Overallocation command (to move to the 
task in the timeline) in the Resource Usage 
view was erratic and inconsistent due to a 

bug when used in Resource Usage view. 
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CREATING AN OVER ALLOCATION REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
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Continue using the 
previous file with this 
exercise, or open the 
file Levelling_3.mpp... 

 
Click on the Report 
tab, then click on 
Resources in the View 
Reports group to 
display a list of reports 

 
Select Overallocated 
Resources to display 
the report 

The report shows which 
resources are over 
allocated and when the 
over allocations 
occur… 

 
Click on the File tab, 
then click on Print 

 
Click on [Print] to print 
the report, or click on 
the Back arrow if you 
prefer not to print 

 
Click on the View tab, 
then click on Resource 
Usage in the Resource 
Views group 

 

Project contains a number of in-built and pre-
defined reports which help you locate all sorts of 
information about, and problems in, your project. 
One such report, the Overallocated Resources 

report, lists all of the resources that are over 
allocated in your project and which tasks contain 
those over allocations. This is a handy report to use 
when levelling your project. 

1 

For Your Reference… 

To create an over-allocated resources report: 

1. Click on the Report tab, then click on 
Resources in the View Reports group 

2. Select Overallocated Resources 

Handy to Know… 

 It is recommended that you print the over-
allocated resources report before 
commencing levelling operations so that you 
have an idea of what is required as well as a 
record to refer back to. 

2 
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CHANGING WORK EFFORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file Levelling_3.mpp... 

 
Click on the View tab, then 
click on Resource Usage in 
the Resource Views group to 
display the Resource Usage 
sheet 

 
Scroll to and click on 
Draftsperson, click on the 
Task tab, then click on Scroll 
to Task in the Editing group 
to display usage information 
for this resource 

 
Click on Gantt Chart in the 
View group to see a Gantt 
Chart view 

 
Point to the information icon 
next to Create architectural 
plans under Planning, then 
right-click on it and select Fix 
in Task Inspector 

 
Click on [Reduce Work] to 
remove the over-allocation 

 
Click on Create architectural 
plans, then click on Details 
in the Properties group to 
see a task form in the lower 
pane of the screen 

Notice that the hours for the 
draftsperson show 112.5h 
(3w x 37.5h)… 

 
Click on the close button of 
the Task Inspector 

 

There is no right or wrong way to level 
over-allocations – the methods that you choose 
are determined by the nature of your project. The 
best way to tackle over-allocations is one at a 

time. We'll start with the Draftsperson. We 
identified a work requirement for two draftspersons 
to create the architectural plans. It has been 
decided that there is only enough work for one. 

1 

2 The problem here is that the task Create architectural plans 
requires/shows 15 hours of draftsperson work on most days – since a 
day is 7.5 hours this means that there is a requirement for 2 draftspeople. 
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For Your Reference… 

To resolve over-allocation by changing work 
effort: 

1. Right-click on the icon next to the task with 
the over-allocation and click on Fix in Task 
Inspector 

2. Click on [Reduce Work] to remove the over 
allocation  

Handy to Know… 

 If you know that reducing the Work will fix an 
over-allocation, you could manually type the 
desired hours in the Work field for the 
resource rather than using the Task 

Inspector. 
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UNDERSTANDING OVERTIME 
 

 

 

 

  

 

You can reduce the overall duration of a resource 
assignment in a task by assigning overtime to 
the resource. The total work for the assigned 
resources remains the same, but the task 

duration is reduced. In Project, overtime is defined 
as the work scheduled to take place beyond the 
regular working hours of the resource. 

The Effect of Overtime On Task Duration 

We have an over-allocation with the riggers. As you'll soon see, this is only in one task – erecting the 
steelwork. In our case study there is a specific amount of work to be done on this. The riggers prepare 
and assemble some of the steelwork units that are then lifted into place. 

We are short one rigger. This shortfall can be overcome by assigning overtime to the other riggers – 
they'll work enough overtime to cover the shortfall of one rigger. 

In Project, assigning overtime can shorten the duration of a task. A task requires a specific amount of 
work effort by the resources to complete the task within the required duration. The duration of the task is 
calculated on the basis that the work effort will be done in regular work time. 

However, if some of that work effort is done in overtime (that is, outside of regular work time) then the 
duration of the task will shorten – providing effort from other resources doesn’t come into play. Consider 
the table below: 

Total Work Ovt Hours Reg Work Time Duration 

15h 0h 15h 2 days 

15h 3.75h 11.25h 1.5 days 

Our task is effort driven and currently requires six riggers per day to complete. 

 

If we take one rigger 
away, the duration will 
be longer – assuming 
that the same amount 
of work needs to be 
done by the five 
remaining riggers. 

However, by assigning overtime we 
should be able to return the duration 
to its original amount. This is 
presented numerically in the form 
below. 
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ASSIGNING OVERTIME 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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Continue using the 
previous file with this 
exercise, or open the file 
Levelling_4.mpp... 

 
Ensure you have a split 
screen view with the 
Gantt Chart and the Task 
Details Form, click in the 
top pane, click on the 
View tab, then click on 
Resource Usage in the 
Resource Views group 

 
In the Gantt Chart, scroll 
down, click on Rigger, 
click on the Task tab, 
then click on Scroll to 
Task in the Editing group 
to display this task in the 
timeline 

 
Click in the Task Details 
Form, click on the Task 
Form Tools: Format tab, 
then ensure Work is 
selected in the Details 
group 

 
Click on 600% in Units for 
Rigger, type 500 and 
click on [OK] 

 
Click on 0h in Ovt. Work 
for Rigger, type 450h and 
click on [OK] 

The task is back to 3 
months and the Rigger 
resource is no longer 
over-allocated 

 

To resolve a resource over-allocation, you may 
need to assign overtime. By definition, overtime 
is something that happens outside of the normal 
working hours. The value in Work represents 

total hours for a resource. Any value in overtime is 
subtracted from the total Work and this in turn may 
impact on the task duration. Generally, more 
overtime results in a shorter task duration. 

The duration has extended to 3.6 months because the Work for the 
Riggers (2,700h) is now divided by 5 riggers to derive total work of 540 
hours for each rigger. Since there are 150 hours of work per week (37.5 
x 5) when you divide the total hours (540h) for a rigger by 150 you get 
3.6 months. 

4 

For Your Reference… 

To assign overtime to a resource: 

1. Ensure a Task Form appears with the Work 
format selected 

2. Type the appropriate overtime in the Ovt. 
Work field, then click on [OK]  

Handy to Know… 

 Project subtracts overtime from total Work 
(2,700 – 450 = 2,250), then divides this by 
the number of specific resources (2,250 / 5 = 
450). This in turn is then divided by the 
number of hours per week (450 / 150 = 3) to 
determine how many weeks of work are 
required by this resource. 
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HIRING CONTRACT LABOUR 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
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Continue using the 
previous file with this 
exercise, or open the file 
Levelling_5.mpp... 

 
Scroll down the Gantt 
chart until the Carpenter 
resource can be seen, 
click on Erect wall, click 
on the Task tab, then 
click on Scroll to Task in 
the Editing group 

 
In the Task Details Form 
click in Resource Name 
below Plumber, type On 
The Hammer, then click 
on [OK] 

We can hire contract 
labour from this agency to 
perform some of the 
carpentry work… 

 
Click on 700% in Units for 
Carpenter and type 
600%, click on 2,100h in 
Work and type 1800, 
then click on [OK] 

 
Double-click on On The 
Hammer to display the 
Resource Information 
dialog box 

 
Change the Units to 
1000%, type OTH in 
Initials and type Contract 
Labour in Group 

 
Click on [OK] 

 

For Your Reference… 

To add a new resource to cover 
over-allocations: 

1. Click in Resource Name, type the name of 
the resource, then click on [OK] 

2. Enter the appropriate Work for this new 
resource, then deduct the same amount from 
the over-allocated resource  

Handy to Know… 

 If you have access to an endless supply of 
contract labour, you will be able to enter a 
large sum of units (such as 1000%). 

Our case study project doesn't have enough 
carpenters to complete the work that needs to be 
done. If it is absolutely necessary, we have 
permission to bring in additional contract 

tradespeople. We will have to add a new resource 
to the pool, then assign the resource to the task, 
being careful that we don't accidentally change the 
duration due to the effort-driven nature of the task. 

3 
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SWITCHING WORK ASSIGNMENTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
Levelling_6.mpp... 

 
Click on Erect seating 
tiers in the Gantt chart, 
click on the Task tab, 
then click on Scroll to 
Task in the Editing 
group 

 
In the Task Details 
Form, type 600% in 
Units for Carpenter, 
then type 675h in Work 

This represents 3 weeks 
work for 6 carpenters (6 
x 3 x 37.5 = 675)... 

 
Type 700% in Units for 
Labourer and type 
787.5h in Work  

This represents 3 weeks 
work for 7 labourers (7 x 
3 x 37.5 = 787.5)... 

 
Click on [OK] to record 
the revised assignments 

The carpenter resource 
no longer appears over-
allocated 

 

For Your Reference… 

To switch work assignments: 

1. Select the task 

2. Adjust the units and/or work effort for the 
over allocated resource 

3. Click on [OK]  

Handy to Know… 

 Switching assignments in Project is relatively 
easy to do, providing you take into 
consideration the effort-driven nature of your 
tasks. 

The task of erecting the seating tiers requires 
eight carpenters, but there are only six in the 
pool. We could use the contract labour, but we 
only have permission to do so if it is absolutely 

necessary. Instead, we can give some of the more 
menial carpentry tasks to the labourers we already 
have. 
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RESCHEDULING TASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

We have an over-allocation of drivers. This over-
allocation has arisen because the resource is 
required on two different tasks at the same time. 
We don't want to use additional resources, and 

overtime isn't practical as the work of the driver is 
required in normal working time. We need to 
reschedule the tasks in such a way that allows us 
to still meet the project deadlines and timeframes.  

Try This Yourself: 

S
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 Continue using the previous file 

with this exercise, or open the 
file Levelling_7.mpp... 

 
Scroll down in the top pane and 
click on the Driver resource, 
click on the Task tab, then click 
on Scroll to Task in the 
Editing group 

 
Use the scroll bar below the 
timeline to scroll right until red 
values appear in the Driver row 

 
Click on Erect wall in the upper 
pane, then click on the Task 
Details Form (lower pane) 

 
Click on the Task Form Tools: 
Format tab, then click on 
Predecessors & Successors 
in the Details group 

 
Click on -10% in Lag, type 0 
and click on [OK] to remove 
the over allocation 

 
Click on the Project tab, then 
click on Project Information in 
the Properties group 

The finish date is now 
Thursday, May 7… 

 
Click on [OK] 

 
Double-click on the divider line 
between the panes to remove 
the lower pane, click on the 
Task tab, then click on Gantt 
Chart in the View group 
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For Your Reference… 

To reschedule an over-allocated task: 

1. Display the predecessors in a task form 

2. Adjust for lag or predecessor relationships  

6 

Handy to Know… 

 When you want to switch to another view 
from a combination view, remember to 
remove the split in the window. For example, 
double-click on the line between the two 
panes, then select Resource Sheet view to 
check that all over-allocations have gone. 
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