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CHAPTER 1 POWER VIEW 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

In this session you will: 

 gain an understanding of how Power View works 
 learn how to enable the Power View add-in 
 learn how to enable the Power View add-in 
 learn how to create a Power View sheet 
 learn how to work with visualisation objects in a Power 

View sheet 
 learn how to manipulate the fields in a Power View report 
 learn how to rearrange and sort fields in a Power View 

sheet 
 learn how to work with measure fields in Power View 
 learn how to format Power View data 
 learn how to tile data 
 learn how to filter data in Power View 
 learn how to switch data visualisations 
 learn how to add more views to a Power View sheet 
 learn how to add titles and a background image 
 learn how to refresh a Power View report. 

Power View is a data exploration, visualisation and presentation tool that 
provides you with the ability to create interactive tables, charts and maps 
from your workbook data through an easy-to-use interface. 
With Power View you can create dashboards that provide alternate and 
complementary views of your workbook data, as well as drilling down into that 
data with filtering and tile grouping. You can see the data in tables and charts 
and switch effortlessly from one to the other. 
Power View is an add-in (only available in the Office Professional Plus and 
Office 365 Professional versions of Office 2016). 

INFOCUS 
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UNDERSTANDING POWER VIEW 
 
 
 
 
  
 

Power View provides a visual and interactive 
way of seeing data that is either currently in a 
workbook or is external to it. A Power View 
report is created in a new sheet. This sheet can 

hold several visualisation objects that interpret 
and analyse the data attached to them. These 
objects can take the form of a table (a bit like a 
PivotTable), a chart or a map. 

The Data 
Generally, the data used for a Power View report will come from some sort of list, either one that has 
been created within the workbook or from an external data source such as a database application like 
Microsoft Access. List data has historically been difficult to analyse without complex data manipulation 
tools. 

The Power View Report 
Using data such as that above a Power View report can be created. The report below contains 2 objects 
– one in tabular format and another in a chart visualisation. Basically, they show the total sales at Honest 
Ted’s Used Cars over three months. There are filter settings at the right which allow even further drilling 
down into the data. 

In this view only sales 
for BMW and 

Volkswagen vehicles 
are shown – these are 
the two vehicle makes 
that have been ticked 

in the filters pane. 

Since there are no 
ticks in any of the filter 
boxes here we are 
seeing an analysis of 
all of the data from the 
data source. Sam
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ENABLING POWER VIEW 
 
 
 
 
 
 
 
  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

O
pe

n 
Fi

le
 Before starting this exercise 

you MUST ensure that 
Excel has started… 

 
Click on the File tab, then 
click on Options to display 
the Excel Options dialog 
box 

 
Click on Add-ins to display 
a list of add-ins currently 
installed in Excel 

 
Click on the Manage drop 
arrow (at the bottom of the 
window), select COM Add-
ins, then click on [Go] to 
display a list of COM Add-
ins available to you 
There are different types of 
add-ins for Excel. COM 
Add-ins are ones that can 
be used by other Office 
applications… 

 
Ensure the checkbox for 
Microsoft Power View for 
Excel appears ticked 

 
Click on [OK] 
There’s no indication at this 
stage that the changes 
have been made 
successfully. We could 
return to the Add-Ins 
settings but for the purpose 
of this exercise we will 
assume the changes were 
successful 

 

Power View is an add-in for Excel 2016 that is 
normally installed when Office and Excel are 
installed. However, it still may need to be enabled 
before it will appear as a tab in the ribbon. 

Add-ins are generally enabled from the Add-Ins 
tab on the Excel Options dialog box. This dialog 
box is accessed through the File tab on the ribbon. 

2 

For Your Reference… 
To enable the Power View add-in: 

1. Click on the File tab, click on Options, then 
click on Add-ins 

2. Click in the checkbox left of Microsoft 
Power View for Excel to enable it 

3. Click on [OK]  

4 

Handy to Know… 
• The Power View add-in is only available to 

you if you are using Office Professional 
Plus or Office 365 Professional Plus. 
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ADDING POWER VIEW TO THE RIBBON 
 
 
 
 
 
 
 
  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Power View is an add-in for Excel 2016 that is 
normally installed when Office and Excel are 
installed. However, it still may need to be added 
to the ribbon as it does not appear by default. 

You can add commands to the ribbon from the 
Customise Ribbon tab in the Excel Options 
dialog box. This dialog box is accessed through the 
File tab. 

Try This Yourself: 

O
pe

n 
Fi

le
 Before starting this exercise you 

MUST ensure that Excel has 
started… 

 
Click on the File tab, then click on 
Options to display the Excel 
Options dialog box 

 
Click on Customise Ribbon to 
display options for customising the 
ribbon 

 
In the right pane, click on Insert to 
select it, then click on [New Group] 
We will add the command to a new 
group on the Insert tab… 

 
In the right pane, right-click on New 
Group (Custom) and select Rename 
to display the Rename dialog box 

 
Type Reports, then click on [OK] to 
apply this name to the new group 

 
Click on the drop arrow under 
Choose commands from, then 
select Commands Not in the 
Ribbon to display commands in the 
left pane that are not already on the 
ribbon 

 
In the left pane, scroll down and click 
on Insert a Power View Report, 
then click on [Add] to add it to the 
new group on the Insert tab 

 
Click on [OK] to return to the 
workbook, then click on the Insert tab 
The Power View command appears 
in the new Reports group at the right 
end of the ribbon 

 

8 

3 

For Your Reference… 
To add Power View to the ribbon: 

1. Click on the File tab, click on Options, then 
click on Customise Ribbon 

2. Click on the required tab and group in the 
right pane 

3. Click on Insert a Power View Report in the 
left pane, click on [Add], then click on [OK] 

7 

Handy to Know… 
• The Power View add-in is only available to 

you if you are using Office Professional 
Plus or Office 365 Professional Plus. 
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CREATING A POWER VIEW SHEET 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

A Power View report is created on a special 
Power View sheet – it’s a bit like having a chart 
on a chart sheet. When you insert a Power View 
report using the Insert tab, a new sheet will be 

created with a new Power View visualisation object 
on it. A Power View Fields pane will appear with 
the fields (columns) shown from the data listing you 
have selected for the view. 

Try This Yourself: 

O
pe

n 
Fi

le
 Before starting this 

exercise you MUST 
open the file Power 
View_1.xlsx… 

 
Click in cell A4  

This is the first cell in 
the list of data. You can 
actually click anywhere 
in the list to create a 
Power View report… 

 
Click on the Insert tab, 
then click on Power 
View in the Reports 
group 

After a few moments a 
new Power View sheet 
will appear with its 
initial interpretation of a 
visualisation based on 
the data from the 
selected list.  

If a message is 
displayed notifying you 
that Power View 
requires a current 
version of Silverlight, 
follow the prompts to 
install or update 
Silverlight, then click 
Reload to try again 

 

1 

For Your Reference… 
To create a new Power View sheet: 

1. Click in any cell of a list 
2. Click on the Insert tab, then click on Power 

View in the Reports group 

Handy to Know… 
• To connect to an external source, you can 

use the Power Pivot add-in to create a Data 
Model within the workbook. When you create 
a Power View report in a workbook that has 
a Data Model the report will automatically 
connect up with the Data Model. 

The table that appears in the Power View sheet above is known as a 
visualisation object. Selection handles (that allow you to resize the object) 
appear around it when it is selected. Also, when it is selected additional 
commands appear on a DESIGN tab. At the right you’ll see the Power 
View Fields pane – the fields that are ticked are the ones currently in use 
in the select visualisation object at the left. 
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WORKING WITH A POWER VIEW OBJECT 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the 

previous file with this 
exercise, or open the file 
Power View_2.xlsx... 

 
Click to the right of the 
table in the Power View 
report to deselect it 

The selection handles 
around the table object 
will disappear and the 
DESIGN tab will no longer 
be available… 

 
Click anywhere on the 
table to select it again 

 
Point to the table, then 
click on Pop out  as 
shown to expand the table 
into the available space 

 
Point to the table, then 
click on Pop in to 
shrink the table again 

 
Point to the table, then 
click on Show Filters  
to see how the data is 
filtered 

 
Click on VIEW directly 
under Filters to show 
filters for the view rather 
than for the table 

There are no filters 
currently applied to the 
view 

 

For Your Reference… 
To work with a Power View object: 

1. Select the Power View object 
2. Point to a selected object to see the Pop out 

tool and the Show Filters tool  

Power View reports are made up of 
visualisations that appear in the Power View 
sheet. These visualisations are objects and you 
can have multiple visualisation objects on a 

Power View sheet, which can enable you to make 
complex dashboards. When a visualisation object 
is selected, handles will appear around it and 
appropriate commands will appear on the ribbon. 

3 

Handy to Know… 
• You can resize a visualisation object by 

dragging its handles. This will enable you to 
see more of the records (rows) or the fields 
(columns). 

5 
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WORKING WITH POWER VIEW FIELDS 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
  
 
 
 
 

The selection of Power View fields at the right of 
the sheet determine what will appear in the 
visualisation object at the left. Unlike 
PivotTables however, the fields do not form a 

rows and columns structure. The fields are more 
like a stack, and each item placed into the stack 
will appear in the object in the order in which it is 
stacked. 

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the previous file 

with this exercise, or open the file 
Power View_3.xlsx... 

 
If necessary, click in the table to 
select it and display the fields in 
the Power View Fields pane  

 
Click in the checkbox for each of 
the ticked fields to remove the 
ticks in order to remove all of the 
fields from the Power View object 

 
If necessary, click on the white 
arrow at the left of Range in the 
fields pane to expand the field list 
again 

 
Click on the checkbox for Month 
to display each month (end) 
included in the table 

 
Click on the checkbox for 
Salesperson to display each 
salesperson for each month 

 
Click on the checkbox for Price to 
see a sum of sales for each 
salesperson for each month 

 
Remove the ticks then try each of 
the following: 
Salesperson, Month, Price 
Make, Price 
Price, Make 
Type, Price 
Payment Method, Price 
Age Grouping, Price 

 

3 

6 

4 

For Your Reference… 
To use fields in the Power View report: 

1. Click on the checkbox next to the desired 
field in the field pane so it is ticked, or 

2. Drag the field from the list to the desired 
position in the stack 

Handy to Know… 
• The order in which the fields are used 

determines the sorting order in the table. 
• You can also drag the fields from the field list 

into the stack. This is handy when you want 
to insert a field in the middle of the stack. 

The order of the stack 
shown in FIELDS above 
determines the column 
order of the table 
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REARRANGING AND SORTING FIELDS 
 
 
 
 
 
 
 
  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the previous 

file with this exercise, or open 
the file Power View_4.xlsx... 

 
Select the table, remove all of 
the ticks in Power View 
Fields, then tick the following 
(in this order): Salesperson, 
Month, Price 

 
Place a tick in Age Grouping 
to add this field to the 
selections 

 
Click on Age Grouping in the 
FIELDS stack, then drag it up 
to below Salesperson 

 
Click on Month, then drag it 
up to below Salesperson 

 
Point to the Age Grouping 
field heading in the table, 
then click once to sort it 

 
Click the heading again to 
sort in descending order 

 
Click on the Month heading 
to sort by month 

 
Click on the Salesperson 
heading to sort by 
salesperson 
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For Your Reference… 
To rearrange and sort fields: 

• Tick the checkbox next to the fields in the 
Power View Fields pane to add them to the 
table 

• Click and drag the fields on or off the 
FIELDS stack  

• Click on the heading in the table to sort it 

You can add or remove fields from the Power 
View sheet by ticking or unticking the field in the 
field pane. You can also drag the fields on or off 
the field stack shown in the FIELDS area on the 

pane. Normally, the order in which fields appear in 
the stack determines the sort order in the view, but 
you can override this by clicking on the field 
headings in the table view. 

3 

Handy to Know… 
• A small triangle appears next to a field name 

in the visualisation table to indicate the 
direction of the sort. An up triangle indicates 
an ascending sort, while a down triangle 
indicates a descending sort. 
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WORKING WITH MEASURE FIELDS 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the 

previous file with this 
exercise, or open the file 
Power View_5.xlsx... 

 
Remove all of the ticks in 
the Power View Fields 
pane, then tick the 
following: Month, 
Payment Method, Price, 
No 

The No field really just 
identifies the transaction 
number and has nothing 
to do with values as such. 
Yet it has been summed 
because it is a measure 
field… 

 
Click on the drop arrow to 
the right of the No field in 
the FIELDS pane 

 
Select Count (Not Blank) 
to count the transactions 
rather than sum them 

 
Click on the drop arrow 
next to Price and select 
Average to see the 
average prices rather than 
the sum 

 

1 

Fields in Power View are either measure or non-
measure fields. Numeric fields are usually, but 
not always, measure fields. A measure field is a 
special type of field used to aggregate with 

operations such as SUM, COUNT, or AVERAGE. 
In Power View, fields that are measure fields have 
a special character (e.g. sigma ∑ is used for SUM 
operations) to the left of the field name. 

2 

3 

For Your Reference… 
To work with measure fields: 

1. Click on the drop arrow next to the field 
name in the FIELDS stack 

2. Choose the appropriate setting for the field 

Handy to Know… 
• You can make a field a non-measure field by 

using the Do Not Summarise option in the 
drop list. 

• The Count (Distinct) setting will count only 
the first instance of duplicate data in a field. 
For example if there are 5 people called 
Smith, only 1 will be returned in the count. 

4 Sam
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FORMATTING POWER VIEW DATA 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the 

previous file with this 
exercise, or open the file 
Power View_6.xlsx... 

 
Click on the first value in 
the Average of Price 
column in the table 

 
Click on the DESIGN tab 
and click on Comma Style 
in the Number group to 
format the numbers 

 
Click on the drop arrow 
that has appeared next to 
Accounting in the 
Number group and select 
Currency to display a 
currency sign next to the 
numbers 

 
Click on the first value in 
Month, click on the drop 
arrow that has appeared 
next to Short Date in the 
Number group and select 
Long Date 

 
Click once on Increase 
Font Size in the Text 
group to increase the 
overall font size 

 

2 

For Your Reference… 
To format Power View table data: 

1. Click on a value in the field to be formatted 
2. Choose the appropriate formatting option 

from the DESIGN tab  

Power View fields appear unformatted even 
though their data source originals may have 
formatting applied to them. Basic formatting 
commands are available on the DESIGN tab 

when a visualisation object is selected. These 
formatting commands allow you to change the 
formatting of numbers and the overall appearance 
of the text – but they are limited. 

3 

Handy to Know… 
• Power View is an add-in to Excel – it is not 

actually part of Excel and has been 
developed in isolation to Excel. Don’t expect 
the same level of rich formatting features in 
Power View as you have in Excel. 

4 Sam
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TILING DATA IN POWER VIEW 
 
 
 
 
 
 
 
  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the previous 

file with this exercise, or 
open the file Power 
View_7.xlsx... 

 
Remove all of the ticks in 
Power View Fields, then 
tick the following: 
Salesperson, Make, Month, 
Price 

 
Click on Salesperson in 
FIELDS and drag it up to the 
TILE BY box 

The names of the 3 
salespeople will now appear 
as tiles at the top of the 
report… 

 
Click on each of the names 
in turn to see the sales that 
each have made 

You may want to drag the 
edge of the object down to 
see the totals better… 

 
Click on the DESIGN tab, 
click on Tile Type in the 
Tiles group and click on Tile 
Flow to see the tiles 
arranged at the bottom of 
the report 

 
Click on the drop arrow to 
the right of Salesperson in 
TILE BY and click on 
Remove Field 

 

Tiling in Power View is a useful way of viewing 
data that has been categorised, by grouping data 
on a particular field. When a field has been tiled 
each of its unique data records appears in a 

scrolling list. As you select each record, other data 
relating to that record is grouped and presented on 
screen for you. 

2 

3 

4 

For Your Reference… 
To tile data in Power View: 

1. Drag the desired tiling field into the TILE BY 
area in the Power View Fields pane 

2. Click on the various tiles to see the data for 
that tile record 

Handy to Know… 
• You can only tile one field in a visualisation 

object at a time. However, there is nothing 
stopping you creating another visualisation 
object and tiling that too. 

Sam
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FILTERING IN POWER VIEW 
 
 
 
 
 
 
 
  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Try This Yourself: 

Sa
m

e 
Fi

le
 Continue using the 

previous file with this 
exercise, or open the file 
Power View_8.xlsx... 

 
Remove all of the ticks in 
the Power View Fields, 
then tick the following: 
Salesperson, Make, 
Month, Price 

 
Drag Salesperson from 
FIELDS up to TILE BY 

 
Point to the table, then click 
on the Show Filters icon to 
see the Filters pane 

 
Click on the arrow to the left 
of Make to see a list of filter 
options 

 
Click in the tick box for 
BMW, then Volkswagen to 
work with only these makes 

 
Click on the tile for Justin 
Callaghan, then Mary 
O’Dwyer to see their sales 
of these vehicles 

You’ll notice that the view 
of the filter settings has 
disappeared… 

 
Click in the data, then click 
on TABLE in the Filters 
pane 

 
Click on the arrow to the left 
of Make, then click in the 
box next to All until it is 
empty to clear all filters 

 

For Your Reference… 
To filter the data in Power View: 

1. Point to the table, then click on the Show 
Filters icon  

2. Click on the arrow to the left of the field to 
filter 

3. Tick the options to filter with 

The Power View sheet provides access to a very 
useful filtering pane. This pane allows you to 
select specific data to show. The process is 
relatively simple and straightforward as each 

unique example of data that can be filtered is 
displayed with a tick box. Ticking a box applies a 
filter on that data. The default shows no ticks 
meaning that all data will be seen. 

4 

3 

Handy to Know… 
• You can also see the Filters pane by clicking 

on the Filters Area command in the View 
group on the Power View tab on the ribbon. 
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