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CHAPTER 1 GETTING TO KNOW FLASH CS5 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Flash CS5 is part of a suite of design, graphics and web tools from 
Adobe.  
Flash is a state of the art web design tool. With Flash you can 
create animated graphic presentations, or “movies” in Flash jargon. 
These animations don’t have to be like cartoons – they can also be 
sophisticated navigation elements like buttons or menus that 
behave in some way out of the ordinary. 
Before you leap into creating anything, it is worth taking some time 
to become familiar with the Flash environment and its features. 

In this session you will: 

 learn how to start Flash CS5 
 gain an understanding of the Flash screen 
 learn how to switch window items on and off 
 Learn how to dock and undock items 
 learn how to use shortcut menus 
 learn how to access the three toolbars in Flash 
 gain an understanding of panels 
 learn how to work with panels 
 learn how to work with Flash workspaces 
 learn hw to run a movie on your default browser 
 learn how to exit Flash. 

INFOCUS 
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STARTING FLASH 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this exercise 
ensure that your computer is 
switched on... 


Click on the Windows Start 
button at the bottom left-hand 
corner of the screen to display 
the menu 

It’s a round button with the 
Windows logo... 


Click on All Programs 


Click on Adobe Flash 
Professional CS5 and wait for 
the program to start 

Unless it has been turned off 
the Welcome screen will 
appear... 


Click on Flash File 
(ActionScript 3.0) under 
Create New to create a new 
Flash file and see the 
standard Flash screen 

 

For Your Reference… 
To start Flash from the Windows Start menu: 

1. Click on the Windows Start button 
2. Click on All Programs 
3. Click on Adobe Flash CS5 Professional 

and either open an existing file or create a 
new one from the Welcome screen 

Handy to Know… 
• There are quite a few choices for creating a 

new Flash file. For standard animations 
choose Flash File (ActionScript 3.0). If you 
need compatibility with earlier versions of 
Flash choose Flash File (ActionScript 2.0). 
The other options are for specialised 
operations. 

1 

2 

When Flash is installed it will be added to the 
standard Windows Start menu and will also 
appear as a shortcut on the desktop. It can be 
started from either of these options. When it is 

started, the default version of Flash will display a 
welcome screen which allows you to open an 
existing Flash file or start a new one. 
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UNDERSTANDING THE FLASH SCREEN 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When you start Flash, one large window will open 
surrounded by a variety of panels. The large 
white part of the screen, known as the Stage, is 
where you will do most of your work. Below the 

Stage you’ll see the Timeline which provides 
access to the various frames of your movie. The 
Flash window always opens showing a blank, 
untitled movie. 


Menu Bar The menu bar runs across the top of the Flash screen. It provides commands and 

options that allow you to work with your Flash file. Each option on the menu bar 
displays a pull-down menu with further commands and options. 

 
Stage The large white area on the screen is known as the Stage, and it is here where you 

draw the pictures that will eventually become your movie animation. The grey area 
around the Stage is referred to as the work area. Here you can place items that you 
don’t want seen when the movie is run – this area is sometimes referred to as the 
Backstage area. 

 
Timeline The Timeline is a complete record of your movie. It shows each scene, each frame 

and each layer of the movie. Frames appear in chronological order. If you click in 
any frame on the Timeline you will be taken to that frame and its contents will 
display on the Stage. The Timeline is actually two dimensional – frames run 
horizontally across the screen while the layers of a drawing run vertically down the 
screen. 


Panels Panels are special areas giving you access to options and settings for the objects 

and things you are working on. For example, if you have a rectangle on the stage 
there will be a panel of settings for changing the colour, size and shape of that 
rectangle. Panels can be docked to the right of the screen or appear to be floating 
so they can be dragged where you like. In addition, the subpanels can be collapsed 
and expanded – a subpanel is expanded when it appears with a downward arrow 

 next to it.  


Toolbars Flash has three toolbars (not shown above) which provide easy access to 

commonly used menu items. 
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WORKING WITH THE FLASH WINDOW 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this exercise 
ensure that Flash has started... 


Select Window on the menu 
bar to see the Window  
pull-down menu 

Items with a tick  on the 
menu will currently appear on 
the screen... 


Click on Timeline and notice 
how the Timeline vanishes 
from the bottom of the screen 


Select Window > Tools to 
remove the Tools panel from 
the right of the screen 


Select Window > Properties 
to remove the Properties 
panel from the screen 

At this point you’ll have a much 
greater area for the Stage... 


Repeat steps 2, 3, and 4 to 
reinstate the items that you 
switched off 

 

For Your Reference… 
To turn on and off main window items: 

1. Select Window > Timeline to switch the 
Timeline on and off  

2. Select Window > Tools to switch the Tools 
panel on and off  

Handy to Know… 
• The characters to the right of menu 

commands represent keyboard shortcuts. 
For example, above you can see that the 
Timeline can be switched on and off by 
holding down  and  and pressing . 

1 

The Flash window can be changed and 
customised to suit the way you work and to 
match the things you are doing. You can add 
items to the screen and also remove the ones 

you don’t presently need. The easiest way to 
achieve this is through the commands in the 
Windows menu on the menu bar. 

Items with an arrow to their right have 
another sub-menu associated with 
them. The sub-menu will appear when 
you hover over or click on the item 
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FLOATERS AND DOCKERS 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this exercise 
ensure that Flash has 
started... 


Move the mouse pointer to 
the dark grey bar to the 
right of the Timeline, as 
shown 


Hold down the left mouse 
button and drag the 
Timeline up so that it floats 
above the Stage 

The Timeline will change 
from docked to floating... 


Drag the Timeline’s grey 
bar to the left until it docks 
to the left of the Stage 


Drag the Timeline’s grey 
bar to the bottom of the 
Stage. When a horizontal 
line appears along the 
bottom of the stage, 
release to dock it at the 
bottom of the screen again 

 

For Your Reference… 
To undock a screen item: 

1. Drag its top grey bar anywhere onto the 
screen 

To dock a screen item: 
1. Drag its top grey bar to the side of a screen 

Handy to Know… 
• Most of the elements on the screen can be 

dragged around. Floating items are great for 
panels and swatches that may be used on a 
casual basis. You can open them from the 
Window command, then position them close 
to your work, and then finally close them 
when you are done. 

1 

2 

Toolbars, panels and other items can be attached 
to a part of the window and when this occurs they 
are referred to as docked. But most items can 
also be dragged around the screen and 

positioned almost anywhere you like. When this 
occurs they are referred to as floating. You can 
change items from floating to docked and vice 
versa. 
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USING SHORTCUT MENUS 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this 
exercise ensure that 
Flash has started... 


Right-click on the stage to 
display a short cut menu 
of commands relevant to 
the stage 


Click on Rulers to display 
rulers at the top and left of 
the stage 


Right-click on the stage, 
click on Grid and then on 
Show Grid to see a grid 
pattern on the stage 


Right-click on the stage, 
click on Grid and then on 
Show Grid to turn off the 
grid pattern again 


Select View > Rulers to 
turn off the rulers 

 

For Your Reference… 
To display a shortcut menu: 

1. Right-click on the item you are working on or 
with to display the relevant shortcut menu for 
that item 

Handy to Know… 
• Most items and operations in Flash have a 

shortcut menu associated with them. In this 
courseware we’ll mostly use the standard 
menu at the top of the screen, but you should 
also right-click during the course to see if 
there is a shortcut menu available and to see 
the options that are there. 

1 

As you would expect with a sophisticated 
application like Flash that has been around for 
quite a while, there are many ways of 
accomplishing the same task. Almost everything 

you can do can be found on the menu structure. To 
make commands easier to access there are also 
short cut menus which are displayed by right 
clicking on a screen item. 
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USING FLASH TOOLBARS 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this 
exercise ensure that 
Flash has started... 


Select Window > 
Toolbars > Main to 
display the Main toolbar 


Select Window > 
Toolbars > Controller 
to display the Controller 
toolbar 


Spend a few moments 
dragging the two 
toolbars around the 
screen 


Click on close  on the 
Main toolbar to close it 


Click on close  on the 
Controller toolbar to 
close it 


Select Window > 
Toolbars > Edit Bar to 
remove the Edit toolbar 
from the top of the stage 


Select Window > 
Toolbars > Edit Bar to 
display the Edit toolbar 
again 

 

For Your Reference… 
To display or hide a toolbar: 

1. Select Window > Toolbars and choose the 
relevant toolbar 

Handy to Know… 
• Don’t confuse the three toolbars (Main, 

Controller and Edit) with the Tools panel at 
the right of the screen. The Tools panel 
contains drawing tools that are used to 
create drawings on the stage. 

1 

2 

Unlike many other applications Flash has only 
three toolbars – Main for opening, closing and 
saving files; Controller for playing movies; and 
Edit for making changes to a movie timeline. The 

Main and Controller toolbars can be docked or 
floating, while the Edit toolbar remains fixed (when 
it is visible) at the top of the screen. Toolbars are 
normally turned off. 
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UNDERSTANDING PANELS 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A panel is a cross between a toolbar and a 
dialog box. Flash has many panels which can be 
switched on and off, and docked or floated, to 
give you a myriad of options and possibilities for 

the organisation of your Flash workspace. Panels 
usually also contain settings that can change items 
and objects on the stage. 

1 


A floating panel can be dragged around and placed almost anywhere on the screen 

 
A docked panel is docked or tied to a specific part of the screen. Notice that there are also 
Properties and Library panels docked below the Colour panel 

 
An embedded panel is placed alongside other panels. Here the Colour panel has been 
embedded with the Properties and Library panels. This is done by dragging the panel into 
another panel to embed it into the existing panel 


Clicking on the Collapse to Icons button will collapse the panel to an icon – great for temporarily 
seeing more of the screen 

 
Double-clicking on the grey bar next to panel tabs will collapse all of the panels. Clicking on it 
again will expand them again 

2 3 
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WORKING WITH PANELS 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this exercise 
ensure that Flash has started... 


Select Window > Colour to 
display the Colour panel group 
docked to the vertical panel bar 

Notice that the Swatches panel 
is docked with the colour 
panel… 


Click on the stage – the Colour 
panel group will close 
automatically 


Click on the Colour icon  in 
the vertical panel bar to open 
the panel again, then drag the 
Colour tab onto the stage to 
float only the Colour panel 


Double-click on the mid-grey 
bar to the right of Colour to 
collapse the settings of the 
panel 


Click on the Collapse to Icons 
button  to collapse the panel 
to an icon 


Click on Expand Panels  to 
expand the panel again 


Drag the panel by its grey bar 
onto the Swatches icon in the 
vertical panel bar, releasing the 
mouse button when a blue line 
surrounds the Swatches icon 

The Colour panel will again be 
docked and grouped with the 
Swatches panel 

For Your Reference… 
To open a panel: 

1. Select Window and choose the panel that 
you wish to open 

Handy to Know… 
• Pressing  will hide all panels on the screen 

(including the timeline which is deemed to be 
a panel). Pressing  again will display all 
panels again. 

1 2 

Panels provide access to the settings required to 
work with objects on the stage. All panels can be 
opened using the Window menu command, but 
the most common panels are even more readily 

available by clicking on their icons in the vertical 
panel bar. The default setting for panels docked in 
this panel bar is that they automatically collapse to 
icons when you’ve finished working with them. 

3 

If you had double-clicked on the 
dark grey bar at the top of the 
panel, the panel would have 
collapsed to icons immediately  

4 
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WORKING WITH WORKSPACES 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this exercise ensure that Flash has started... 


Select Window > Workspace > Animator to see the screen (oops, workspace) set up for 
animations 


Select Window > Workspace > Classic to see the classic workspace of Flash 


Click on the Classic button at the top of the screen to see a menu of available built-in 
workspaces 


Click on Essentials to return to the Essentials workspace 


Select Window > Workspace > Reset ‘Essentials’ to reset the Essentials workspace to its 
Flash defaults 

For Your Reference… 
To choose a preset workspace: 

1. Select Window > Workspace and click on 
the workspace you’d like to see, or, 

 Click on the workspace button at the top of 
the screen and click on the desired 
workspace to switch to 

Handy to Know… 
• Flash remembers your current workspace 

when you save a file. When you open an 
existing Flash file all of the workspace 
settings are displayed as they were when the 
file was last saved. 

1 

All of the items and their settings currently on the 
screen at any time are known as a workspace. 
Given there are so many panels and toolbars at 
your disposal there are a myriad of ways your 

workspace could appear at anytime. Flash also has 
some built-in workspaces designed to show 
relevant panels when working on specific Flash 
operations. 
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RUNNING A FLASH MOVIE 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this 
exercise ensure that 
Flash has started... 


Select File > Open to 
display the Open dialog 
box 


Navigate to the 
C:\Course Files for 
Flash CS5 folder 


Click on Publish1.fla and 
click on [Open] 


Press  to publish the 
file to your default web 
browser – this will take a 
few moments 


Right-click on the movie 
as it is playing and select 
Loop to stop it looping 


Right-click on the movie 
and select Play to start it 
playing again 


Click on the browser’s 
close button  to 
close the browser 

 

For Your Reference… 
To publish a movie to the web browser: 

1. Open the Flash file 
2. Press  to publish the movie to your default 

web browser 

Handy to Know… 
• You can also play the movie from within 

Flash. Publishing it to the web browser lets 
you see how it will appear when running on 
the Web. 

2 

Flash is an animation tool and the animations are 
designed to be played. Animations can be 
played in a number of ways. To play your 
animation in a web browser, the animation needs 

to be published. Flash working files can be 
identified by the three letters fla that appear at the 
end of the file name. Published movies instead 
have the three letter file extension .swf. 
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EXITING FLASH 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Try This Yourself: 

 Before starting this exercise 
ensure that Flash has started... 


Select File > Exit 

If you currently have a movie 
file open that contains unsaved 
changes you will be asked if 
you wish to save the file before 
exiting... 


We haven’t really created or 
changed anything that we wish 
to keep at this stage so if the 
save prompt appears, click on 
[No] 

 

For Your Reference… 
To exit Flash: 

1. Select File > Exit 

Handy to Know… 
• Flash movies are saved in a file that ends 

with .fla. When you save a file, you are 
saving the fla file and not any files that have 
been published while using the movie. 

1 

When you have finished watching your television 
you simply turn it off – do that with a computer 
and there is the potential to lose your work. In 
applications the safest way to exit is to use the 

commands on the File menu. Using the File menu 
options, you can either Close a file and remain in 
Flash, or Exit which both closes any open files and 
takes you out of Flash. 
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